Indonations – Bonding allows many ethernet connections to be bundled into one virtual link, allowing it to deliver higher data rates and provide a failover link.

Using MikroTik to Set Up the Bonding Interface

Let’s say that we want to get the greatest data rate/bandwidth between two routers, and each router has two ether ports (Router 1 and Router 2). Here’s how to do it in Mikrotik Versi Penulistech :

 ether2 ================================== ether2
MikroTik1 <<==== bonding interface ====>> MikroTik2
 ether3 ================================== ether3

Setting Bonding Interface on Router 1

Add the bonding interface and IP Address:

/interface bonding
 add \
 slaves=ether2,ether3 \
 disabled=no
/ip address
 add \
 address=192.168.200.1/24 \
 interface=bonding1 \
 disabled=no

Setting Bonding Interface on Router 2

Add the bonding interface and IP Address:

/interface bonding
 add \
 slaves=ether2,ether3 \
 disabled=no
/ip address
 add \
 address=192.168.200.2/24 \
 interface=bonding1 \
 disabled=no

Test connection / link from router 1 to router 2:

[[email protected]] interface bonding> ping 192.168.200.2
192.168.200.2 ping timeout
192.168.200.2 ping timeout
192.168.200.2 ping timeout
192.168.200.2 64 byte ping: ttl=64 time=2 ms
192.168.200.2 64 byte ping: ttl=64 time=2 ms

Now we’ll use the bonded interface to try and test the maximum data rate / bandwidth produced between Mikrotik routers.

When testing the bandwidth on both ether2 and ether3 connections between mikrotik 1 and mikrotik 2, you get a maximum Rx of 100Mbps on each ether. When bonding together, you get a maximum Rx of 200Mbps.

How to Configure the Interface for Link Monitoring and Failover Bonding

As I previously said, a bonding interface acts as a failover in addition to being applied. If one of the links in the example above fails, bonding will continue to transmit packets over it and cause network degradation until it is repaired. As a result, connection monitoring, such as ARP Monitoring, must be enabled on the bonding interface.

Enabling ARP Monitoring on Both Mikrotik

Routers 1

/interface bonding set 0 link-monitoring=arp arp-ip-targets=192.168.200.2

Routers 2

/interface bonding set 0 link-monitoring=arp arp-ip-targets=192.168.200.1

When arp monitoring detects a link break, you will see multiple timeouts until you unplug one of the cables to confirm that the monitoring link is working appropriately.